CinchV2 DemoApp

Oct 16, 2010 at 8:50 AM

Hi Sacha,

I've tried to start the CinchV2 Demo App, but when trying to setup the "CinchBootstrapper" the application crashes.

Digging deeper, i've found out that it crashes in line 20 in CinchBootstrapper.cs : "PopupResolver.ResolvePopupLookups(assembliesToExamine);".

There is a "ReflectionTypeLoadException" thrown, that tells me, that at least one Type of the assembly could not be loaded.

The Build Number i've downloaded is: 51807

Do you have any idea why it is not working at my mashine? Iam using Visual Sutio 2010.

Hope you can help, because i want to use these great framework :-)

Best Regards,


Oct 17, 2010 at 9:49 AM

Just checked all is fine with me and that release at work/at home, and on laptop. Are you sure its not something silly like your project type being .NET Client Profile, make sure All your projects target .NET 4.0 not .NET Client Profile, that caused me issues in the past. VS2010s default project type is to use Client Profile, which is shit in my opinion, it is easily forgotten.

Oct 17, 2010 at 12:46 PM

So, i've changed the .Net Profile of the Demo App to .Net 4, but the same error occur :(

Do you maybe have an idea, what other misconficuration could prevent the demo app from running correctly? I think there must be something on my mashine....but i really have no idea what it could be...i also have the Blend 4 SDK installed...

Oct 17, 2010 at 3:01 PM

Is this SL or WPF we are talking????


For WPF demo you need to make sure App.Config points to valid image directory.


Other than that there is no config to check.....You may have to try and step into boostrapper code, which you will be able to do if you copy the debug symbols to your project location.

Oct 17, 2010 at 5:07 PM

It's WPF.

I've changed my App.config to a valid directory, but thats not the failure. I've debugged bootstrapper code and it crashes in file "PopupResolver.cs", line 20-21, the code is:

IUIVisualizerService uiVisualizerService  =

When i change the code in App.cs in the DemoApp to that:

//CinchBootStrapper.Initialise(new List<Assembly> { typeof(App).Assembly });
ViewResolver.ResolveViewLookups(new List<Assembly> { typeof(App).Assembly });

to directly lookup the views, the programm starts, but there are no tab items in the tab control.

Any idea why the app is crashing in "PopupResolver.cs" ?



Oct 18, 2010 at 7:20 AM

You will need to find the exact Exception, I suggest you turn on Exceptions, go into Debug menu, then Exceptions, and turn on Exceptions. See what Exception is being thrown

Oct 18, 2010 at 11:19 AM

Well, I've found out, what's the error about: The Assembly System.Windows.Interactivity could not ne loaded, because of a wrong Reference on my mashine. I've fixed that reference, and now, the Demo App is running :-)

Oct 18, 2010 at 3:11 PM

Good good